
 

 

 

 

 

 

 

 

 

 

 

 

英创嵌入式模块使用必读 
（ARM9 系列）

Emtronix 



英创信息技术有限公司                                 英创嵌入式模块使用必读(ARM9 系列)V8.01 

www.emtronix.com                                                              028-86180660 2

感谢您选择英创的 ARM9 系列嵌入式模块产品。 

 

正是有了广大客户的支持和厚爱，英创才能够精益求精，开发出更多更好的适合用户需

求的产品，才能够给用户提供更优质的服务。 

 

为了让您能够尽快地使用好我们的嵌入式模块，英创公司编写了这篇《使用必读》，我

们建议每一位使用英创 ARM9 产品的客户都浏览一遍。我们本着通俗易懂的原则，按照由

浅入深的顺序，采用了大量的图片和浅显的文字，以便于客户能边了解、边动手，轻松愉快

地完成产品的开发。 

 

在开发和使用英创嵌入式模块的过程中，如果您遇到难题，需要帮助，您可以通过以下

三种方式寻求英创工程师的技术支持。 

 

1、直接致电 028-86180660  85140028  85137442  85136173 

2、技术支持邮件 support@emtronix.com 

3、登录 http://www.emtronix.com，在技术论坛上直接提问 

 

再次谢谢您的支持！ 
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1  搭建硬件开发平台 

 

1.1  必要的准备 
新客户最初购买的第一套英创 ARM9 嵌入式模块产品往往包括该型号的嵌入式模块基

本开发套件，这套开发套件包括： 

 一块该型号的嵌入式模块 

 一块与该型号嵌入式模块配套的开发评估底板 

 一块视频信号转换板（ETA921） 

 一条串口连接线 

 一条以太网络连接线 

 一条直流电源线 

 一张开发资料光盘 

 Microsoft 公司的 Windows CE core 的正版授权标贴 

 

英创嵌入式模块两侧有双排插针，这两排插针将嵌入式模块的板载接口资源引出，而开

发评估底板上安装有相对应的接口插座，因此，嵌入式模块就象一个大芯片一样对插在与该

嵌入式模块相配套的开发评估底板上，从而形成一套较完整的开发系统。 

 

新客户要在英创嵌入式模块开发套件的基础上进行进一步的开发，需要作如下一些必要

准备： 

 准备一台具有+5V 电压输出的普通直流稳压电源或开关直流电源（+5V±5%），将

英创提供的直流电源线正确地连接到该电源的+5V 输出上（注意极性） 

注：如客户需进行 GPRS/CDMA 应用开发，由于 GPRS/CDMA 通讯模块发射的

瞬间电流可达 2A，建议选择输出功率大于 10W 的开关电源。 

 准备一台带以太网接口和至少一个 RS232 串口的 PC 机作为开发主机，该 PC 机

安装 Windows XP 操作系统 

 用户应当拥有一个能让嵌入式模块和开发主机接入的以太网络（英创公司提供的网

线是开发板连交换机的网线，不是双机互联线，一般不能直接连 pc 机） 

 一只可以供英创模块单独使用的 USB 鼠标 

 一只可供临时存储数据的 U 盘 

 

根据客户所开发的产品不同的需求，除了以上一些客户开发的必要配备外，客户可能还

有一些其它开发附件，如： 

 英创提供的其它配套模块产品，如串口扩展模块、IO 扩展模块等等 
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 GPRS/CDMA 通讯模块（如：Siemens MC39i）以及天线等附件 

 客户所需要的其它附件 

这些附件的配套使用方法，客户请参考该产品的使用说明或手册。 

 

1.2  开发环境的硬件连接和安装 
在以上条件准备好以后，就可以进行开发环境的硬件连接了。 

标准配置的英创 EM9161 嵌入式模块板上配有内存和 NandFlash，并内置了正版

Windows CE 操作系统，客户在开发主机上使用 eVC 开发应用程序，并通过以太网和英创

嵌入式模块进行连接、传输文件和调试。如客户的程序或数据需要更大的空间来存放，可以

考虑使用板载的 MiniSD 卡接口。 

嵌入式模块配套开发评估底板上包括 3 路 RS485 单元、2 路 RS232 插座等连接器件、

VGA 接口、4x4 矩阵键盘接口、USB 接口和以太网络接口等，这些接口直接面向用户，在

EM9161 开发评估底板手册中详细讲解了底板的硬件接口的功能和用法。开发评估底板不仅

可以方便开发者的线缆连接，同时在开发光盘上提供的原理图和 PCB 图还可以为开发者进

行外围电路设计时提供一定的参考，以便开发者在此基础上进行增加或者删减电路单元，重

新进行适合自己产品需求的定位，快速地构成自己的应用产品。 

嵌入式模块有两种工作模式：运行模式和调试模式。请注意，开发评估底板上有一颗可

在运行模式和调试模式之间进行切换的跳线 JP1，若该跳线器断开，系统将进入正常运行模

式；短接时，系统将以调试模式启动，如图 1-1。客户在进行开发调试时，总是让嵌入式模

块处于调试模式，即 JP1 处于短接状态。在正常进行调试或运行应用程序之前，客户还需

要通过编辑两个应用文本文件（dbginfo.txt / userinfo.txt）来对系统进行软件通讯配置（具

体配置方法将在后文进行交代）。 

 
图 1-1  JP1，模式切换跳线器 

 

将开发主机接入以太网络。同时，将英创嵌入式网络模块也接入以太网，如图 1-2。这

样开发主机和嵌入式模块就能够建立起网络连接。 
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图 1-2  将英创嵌入式模块接入以太网 

 

显示对于大多数使用 Windows CE 系统的客户来说是很重要的，因此英创 ARM9 嵌入

式网络模块评估底板上包括 VGA 视频输出接口，客户可以通过评估底板上 VGA 视频输出

接口直接连接一台 VGA 显示器。VGA 接口如图 1-3 所示。 

 
图 1-3  VGA 接口 

 

也有部分客户选择数字 TFT LCD 显示输出，英创 ARM9 嵌入式模块支持数字 TFT LCD

的直接连接，如图 1-4 所示，可将 TFT LCD 的视频显示线缆直接与视频信号转接板连接（连

线的排列请参考 LCD 手册和英创相关手册）。 

 

图 1-4  连接数字 TFT LCD 

然后，将准备好的 USB 接口鼠标接入开发底板的 USB 接口（英创 ARM9 模块提供了

2 个 USB HOST 接口，一般将鼠标接入下端的 USB 口，上端的 USB 口空出备用）。这样，

基本的硬件连接就结束了。如图 1-5 所示。 
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图 1-5  基本硬件连接 

现在可以给嵌入式模块进行通电，即将 5V 直流电源线接头插入嵌入式模块配套底板上

的电源插头（注意正负极方向），见图 1-6，此时，嵌入式模块上的红色电源 LED 指示灯亮。

稍候，显示器上将显示 Windows CE 桌面，如图 1-7 所示，表示系统启动成功。 

 
图 1-6  开发系统上电 
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图 1-7  Windows CE 桌面 

 

这样基本的硬件环境就连接完毕了，总结之，所搭建的开发环境如图 1-7 所示。 

 
图 1-8  英创 ARM9 嵌入式模块开发环境功能框图 
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2  工作模式选择 

 

2.1  工作模式介绍 

英创 ARM9 嵌入式模块有两种工作模式：调试模式和运行模式。在配置软件开发环境

之前，用户需要对这两种工作模式有所了解，以便于进行应用开发。 

调试模式是指开机以后系统处于调试状态，此时用户可以通过 eVC 及其远程调试工具

来操作英创模块，实现应用程序下载调试、文件管理等功能。在开发阶段，系统总是处于这

种状态下。 

运行模式是指开机以后系统自动开始执行用户指定的程序。开发完成，进入实际应用时

系统总是处于这种状态下。 

英创 ARM9 嵌入式模块工作于上述的哪一种模式，是通过开发底板上的跳线器 JP1 来

选择的（JP1 在评估底板的具体位置见图 1-1）。JP1 短接，则工作于调试模式；JP1 断开，

则工作于运行模式。 

 

2.2  系统配置文件说明 

除设置跳线器以外，用户还需要修改两个重要的文件 dbginfo.txt 和 userinfo.txt 来为

系统的调试/运行配置必要的参数。 

 

2.2.1  dbginfo.txt 

dbginfo.txt 所保存的是在调试状态下目标机和开发主机的网络参数，要对系统进行开发

调试，则必须事先将该文件编辑完成并存于英创模块的“NandFlash”目录中（依据具体的

模块型号）。其内容及格式如下（双斜线后的蓝色部分为加注的说明文字，并不包括在文件

中）： 

[LOCAL_MACHINE]              //目标机信息 

DefaultGateway="192.168.201.8"  //默认网关，根据用户所在网络的实际设置填写。

如果填为 0.0.0.0，则表示保留原有的配置 

IPAddress="192.168.201.205"     //目标机 IP 地址，由用户自行设置 

SubnetMask="255.255.255.0"     //子网掩码，根据用户所在网络的实际设置填写 

[HOST_MACHINE]               //开发主机信息 
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IPAddress="192.168.201.4"       //开发主机 IP 地址，根据用户主机的实际设置填写 

port="9300"                     //端口号，采用默认值 9300，不能修改 

[SYSTEM]                      //存储空间调整 

Store="50"                      //系统文件和用户文件各占用 50%的存储空间（注） 

编辑好 dbginfo.txt 并存入 U 盘，将 U 盘接在开发底板的 USB 接口上，短接 JP1，然

后上电启动，系统自动会把这个文件存入到“NandFlash”目录中，并读取其内容作为默认

配置。如果用户的调试环境网络参数没有改变，则今后上电启动的时候无需再接 U 盘，调

试启动时，系统将从“NandFlash”目录读取配置参数。如果网络参数发生了变化，则用户

应该按照新的参数修改 dbginfo.txt，并再次通过 U 盘把这个文件复制到系统的“NandFlash”

目录中，以此让系统接收新的配置。 

注：Store 用于分配存储空间，双引号中间的数字表示系统文件占用的存储空间百分比。

英创公司出厂默认将 NorFLASH 均分给系统和用户（即各占 50%），用户可以通

过设置该参数调节这一比例以适应自己的需求。例如，用户程序需要占用 70%的

存储空间，则应该如下设置：Store="30"。该参数的有效范围在 10-90，小于 10

或者大于 90 的设置将视为无效操作，此时系统采用默认配置。 

 

2.2.2  userinfo.txt 

userinfo.txt所保存的是在运行状态下目标机的网络参数和开机自动运行的程序的参数，

要让系统开机自动运行应用程序，则必须事先将该文件编辑完成并存于英创模块的 

“NandFlash”目录中。文件内容及格式如下（双斜线后的蓝色部分为加注的说明文字，并

不包括在文件中）： 

[LOCAL_MACHINE]              //目标机信息 

DefaultGateway="192.168.201.8"  //默认网关，根据所在的实际运行网络来设置。该

网关地址与 dbginfo.txt 中的设置不一定相同 

IPAddress="192.168.201.205"     //目标机 IP 地址，由用户自行设置。该 IP 地址与

dbginfo.txt 中的设置不一定相同 

SubnetMask="255.255.255.0"     //子网掩码，根据所在的实际运行网络填写，该子

网掩码与 dbginfo.txt 中的设置不一定相同 

[USER_EXE]                    //用户程序信息 

Name="serialtest.exe"            //系统开机自动执行的程序，默认为 serialtest.exe。
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实际开发完成以后用户将自己的应用程序文件名

填在双引号之间取代目前的默认文件名，开机即

可自动运行（注） 

Parameters="COM1 9600"      //系统开机自动执行的程序的参数配置。此处为

serialtest.exe 的参数：测试 COM1，波特率为

9600。开发完成以后在此处填入实际应用程序的

参数，如果没有则不填，但必须保留双引号 

[SYSTEM]                      //存储空间调整 

Store="50"                      //系统文件和用户文件各占用 50%的存储空间（注） 

 

注：1、程序“serialtest.exe”是存放于 WinCE 默认的系统文件夹下面，故此处没有

指定其存放位置；而实际的用户应用程序总是放在系统的“NandFlash”或“SD 

Memory Card”目录当中，因此用户在编辑 userinfo.txt 的时候应该指定应用程

序的位置，即“Name”属性应该如下所示（此处仍以 serialtest.exe 为例）： 

     Name="\NandFlash\serialtest.exe" 

2、Store 参数的含义及使用方法同 userinfo.txt。 

 

 

编辑好 userinfo.txt，将开发主机与英创 ARM9 嵌入式模块建立连接，通过 eVC 将该文

件以及文件中所指定的应用程序复制到“NandFlash”（建立连接以及文件复制的方法见后

文），接下来断开 JP1，然后上电启动，系统会读取 userinfo.txt 中的内容作为默认配置，并

按照该文件的设置运行指定应用程序。如果用户需要修改应用程序，则可以按照新的参数修

改 userinfo.txt，并再次通过 eVC 把这个文件以及新的应用程序复制到系统的 “NandFlash”

录中，以此让系统接收新的配置。 

注：1、如果只是程序本身发生变化而网络参数、程序名字和参数均不变，则无需修改

此文件。 

2、如果仅仅是开发调试阶段，则无需编辑 userinfo.txt。 
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3  软件开发环境的安装和配置 

 

基于 WinCE 的应用软件开发是通过 eVC 开发工具进行的，其过程和方式均很类似于

使用 VC 开发桌面 Windows 的应用程序。eVC 是 Microsoft 针对嵌入式系统开发而提供的

专门开发工具，可直接从 Microsoft 的网站下载。本节将介绍 eVC 的安装过程以及软件开发

环境的搭建，所需的软件均包括在开发光盘的“eVC 安装”和“SOFTWARE”目录下。 

 

3.1  eVC4 和 eVCsp4 的安装 

1、在安装 eVC 之前，用户首先需要安装 Microsoft .NET Framework 1.1。运行“eVC

安装/Dotnetfx”目录下的 Dotnetfx.exe，到出现如图 3-1 所示的许可协议对话框，选择 同

意 并安装。 

 

图 3-1  同意 Microsoft .NET Framework 1.1 许可协议 
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2、.NET Framework 1.1 的安装过程如图 3-2 所示。 

 

图 3-2  Microsoft .NET Framework 1.1 安装过程 

 

3、.NET Framework 1.1 安装完毕以后就可以进行 eVC4.0 的安装。运行“eVC 安装

/eVC4”目录下的 setup.exe，系统自动载入相关信息，过程中全部直接 next，使用系统默

认的设置，至出现如图 3-3 所示的许可协议对话框，选择 I accept the agreement，同意安

装协议。 

 
图 3-3  同意 eVC4.0 安装协议 
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4、接下来将出现序列号对话框，打开“eVC 安装/key”文件夹，将文件中的序列号填

入，如图 3-4。 

 
图 3-4  填写安装序列号 

 

5、在安装项目选择中去除 Standard SDK for Windows CE .NET，如图 3-5。 

注意：此处如果操作失误，PC 机将不能和板子正常连接。 

 

图 3-5  去除 WinCE 的标准 SDK 
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6、系统提示安装 Windows CE Platform Manager，确认安装，如图 3-6。 

 
图 3-6  确认安装 WinCE Platform Manager 

 

7、WinCE Platform Manager 的安装过程如图 3-7。 

 

图 3-7  安装 WinCE Platform Manager 

 

8、安装完毕以后，系统会提示关闭所有的应用程序，选择 Continue，如图 3-8，并在

接下来的几个对话框中均选择 OK。 

 
图 3-8  确认关闭应用程序 
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9、接下来出现安装确认对话框如图 3-9，不作任何修改，直接确认安装（建议客户不

要修改默认的安装路径，以免以后使用时出现错误）。 

 

图 3-9  确认安装信息 

 

10、系统开始安装 eVC4.0，如图 3-10。 

 
图 3-10  eVC4.0 安装过程 
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11、eVC4.0 安装完成以后，即可安装 eVC4sp4。运行“eVC 安装/eVCsp4”目录下的

setup.exe，至如图 3-11 所示的许可协议对话框，选择 I accept the terms in the License 

Agreement，同意安装协议。 

 

图 3-11  同意 sp4 安装协议 

 

12、系统开始安装 sp4，如图 3-12。 

 

图 3-12  安装 sp4 
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13、sp4 安装完成以后，运行“SOFTWARE/SDK”目录下包含的所购模块的 SDK 安

装程序，本文以 EM9161_SDK.exe 为例。至出现如图 3-13 所示对话框，选择 Accept，同

意安装协议。 

 
图 3-13  同意 SDK 安装协议 

 

14、出现如图 3-14 的对话框时选择 Complete。 
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图 3-14  选择完全安装 

15、安装过程如图 3-15。完毕以后，需要的软件即全部安装完成。 

 
图 3-15  SDK 安装过程 
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3.2  软件开发环境的配置 

1、安装完成上述软件以后。打开“SOFTWARE/config”目录，将里面的 dbginfo.txt

复制到本地硬盘，并根据用户所在的网络修改其内容（关于这个文件的说明见第二章）。 

以笔者的开发环境为例。本地网关为 192.168.201.8；开发主机的 IP 地址为

192.168.201.190；子网掩码为 255.255.255.0；为英创 ARM9 嵌入式模块分配的 IP 地址为

192.168.201.193。 

则 dbginfo.txt 文件的内容应编辑如下： 

[LOCAL_MACHINE] 

DefaultGateway="192.168.201.8" 

IPAddress="192.168.201.190" 

SubnetMask="255.255.255.0" 

[HOST_MACHINE] 

IPAddress="192.168.201.193" 

port="9300" 

[SYSTEM] 

Store="50" 

 

    2、修改完成后保存这个文件并复制到 U 盘上面，然后将 U 盘接在开发套件的 USB 接

口上，上电启动英创 ARM9 嵌入式模块。 

注：1、U 盘必须为 FAT 文件系统，否则英创 ARM9 嵌入式模块无法正确读取其内容。 

2、dbginfo.txt 必须在调试之前即通过 U 盘读入到英创 ARM9 嵌入式模块中。此后

如果没有修改，则无需每次开机都重新载入。如果配置有变，则修改该文件以

后再次通过 U 盘存入英创 ARM9 嵌入式模块即可。 

 

3、开机后英创 ARM9 嵌入式模块会读取 U 盘的内容，用户可以看见 U 盘上的指示灯

闪动。读取完毕（即 U 盘上的指示灯停止闪动）以后，在开发主机上启动 eVC，然后选择

Tools->Configure Platform Manager…，如图 3-16。 
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图 3-16  配置软件环境 

 

4、在打开的对话框中选择目标设备（如：EM9161 Device），然后选择右边的

Properties…，如图 3-17。 

 
图 3-17  修改英创 ARM9 嵌入式模块的配置 
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5、在 Device Properties 对话框的 Transpor 中选择 TCP/IP Transport for Windows 

CE，在 Startup 中选择 Manual Server，然后选择 Transpor 右边的 Configure…，如图 3-18。 

 

图 3-18  选择要修改的属性 

 

 

6、勾选 Fixed port，并在其右边的 Port number 中输入 9300。然后在 Use fixed address

右边选择开发主机的 IP 地址。以笔者的开发环境为例，应该是 192.168.201.190，如图 3-19。 

 

图 3-19  配置网络端口和开发主机的 IP 地址 

 

7、连续选择 OK，关掉三个对话框。然后选择 Tools->Remote File Viewer(WCE500)，

如图 3-20 所示。 
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图 3-20  选择 Remote File Viewer 

 

8、在弹出的对话框中选择目标设备（如：EM9161 Device），如图 3-21 所示。 

 
图 3-21  选择英创 ARM9 嵌入式模块 Device 

 

9、选择 OK 确认弹出的信息，系统开始与英创 ARM9 嵌入式模块建立连接，如图 3-22。 
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图 3-22  开发主机与英创 ARM9 嵌入式模块建立连接 

 

10、连接建立以后，将显示出当前英创 ARM9 嵌入式模块的文件信息，如图 3-23。至

此，软件开发环境安装配置完成。 

 

图 3-23  连接成功，主机端显示出的英创 ARM9 嵌入式模块当前文件信息 
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4  使用 eVC 开发第一个程序：hello 

 

建立好英创 ARM9 嵌入式模块所需的硬、软件开发环境，并利用以太网将开发主机和

英创 ARM9 嵌入式模块连接成功以后，用户就可以通过 eVC 开发、调试自己所需的应用程

序了。 

eVC 开发环境和普通的 VC 非常相似，客户可以通过市面上很常见的大量 VC 书籍资料

来进行编程方面的学习。然而，使用 eVC 开发和 VC 的最大区别之一在于：VC 开发的程序

直接运行于普通 PC 机；eVC 开发的应用程序最终要在目标机而非 PC 机上运行调试。这一

过程是广大 VC 程序员和刚接触嵌入式系统的工程师所不熟悉的。因此，下面将通过一个简

单实例来介绍如何使用 eVC 开发并在目标机上使用调试模式和运行模式运行程序。 

 

4.1  在调试模式下运行程序 

1、英创 ARM9 嵌入式模块正常启动以后的显示画面如图 4-1 所示。 

 
图 4-1  英创 ARM9 嵌入式模块正常启动以后的显示画面 
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2、启动 eVC，选择 File->New…，如图 4-2 所示。 

 

图 4-2  在 eVC 中新建 

 

3、在 Projects 选项卡中选择 WCE Application，并在右边 Project name 中输入工程

名字 hello，在 Location 中指定该工程的存储位置，如图 4-3 所示。 

 

图 4-3  新建工程 
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4、接下来的对话框中选择 A typical “Hello World!” application.，如图 4-4 所示。然

后选择 Finish，并选择 OK 确认弹出的工程信息对话框，工程 hello 即建立完毕。 

 

图 4-4  选择工程类型 

 

5、eVC 的文件管理、编辑方式和 VC 一样。图 4-5 所示是 hello 中的文件。 

 
图 4-5  工程 hello 中的文件 

6、hello 是 eVC 自带的工程文件，无需用户编码，可以直接编译运行。点击右上角工

具栏中的红色感叹号（也可以通过菜单栏的 Build->Execute hello.exe 或者通过快捷方式
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Ctrl+F5 执行该命令），如图 4-6 所示，并连续选择 OK 以确认弹出的对话框，工程开始编

译执行。 

 

图 4-6  编译运行 hello 

 

7、编译成功后 eVC 将自动连接目标机并执行程序。执行完毕以后，目标机将显示如图

4-7 的执行结果画面。 

 

图 4-7  目标机执行 hello 之后的显示画面 

 

现在，hello 程序已经成功地通过 eVC 编译，并已调试模式在目标机上运行。 

 

 

 

4.2  在运行模式下运行程序 

1、选择 Tools->Remote File Viewer(WCE500)，连接建立以后，打开“EM9161 
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Device”，可以看到 hello.exe 已经复制到了 EM9161 的根目录当中，如图 4-8 所示。 

 
图 4-8  EM9161 目录中的文件 

 

2、打开“SOFTWARE/config”目录，将里面的 userinfo.txt 复制到本地硬盘，并根

据用户所在的网络修改其内容（关于这个文件的说明见第二章）。 

以笔者的开发环境为例。本地网关为 192.168.201.8；子网掩码为 255.255.255.0；为

英创 ARM9 嵌入式模块分配的 IP 地址为 192.168.201.193；要运行的文件是 hello.exe；无

参数。 

则 userinfo.txt 文件的内容应编辑如下： 

[LOCAL_MACHINE] 

DefaultGateway="192.168.201.8" 

IPAddress="192.168.201.193" 

SubnetMask="255.255.255.0" 

[USER_EXE] 

Name="\NandFlash\hello.exe" 

Parameters="" 
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[SYSTEM] 

Store="50" 

注：userinfo.txt 仅仅是在需要系统工作于运行模式的时候才编辑并上传至英创模块中。

如果系统工作于调试模式，则无需这个文件。同时，该文件中的网络参数在很多情

况下与 dbginfo.txt 中的并不一样，要根据系统的实际工作环境设置。 

 

3、点击右上方工具栏中的黄色向上箭头（也可以通过菜单栏的 File->Export File 执行

该命令），如图 4-9 所示，在弹出的对话框中选择刚才编辑好的 userinfo.txt，确认，将其

复制到英创模块中（此例中需要使用同样的方法把 hello.exe 复制到“NandFLASH”目录

中）。 

 

图 4-9  下载 userinfo.txt 

 

4、断开开发底板上的 JP1，重启系统，开机以后系统自动执行程序 hello.exe，显示画

面如图 4-7 所示。则在运行模式下运行应用程序成功。 

 

到此为止，用户已经搭建完成英创 ARM9 嵌入式模块的开发环境，并成功运行第一个

示例程序，接下来可以针对自己的实际应用进行开发了。 


