共有1604人关注过本帖树形打印复制链接

主题:【新手求助】eclipse编译的程序无法在ESM6800运行

帅哥哟,离线,有人找我吗?
linux新手
  1楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信
等级:新手上路
【新手求助】eclipse编译的程序无法在ESM6800运行  发帖心情 Post By:2018-4-14 15:57:00 [只看该作者]

初学arm linux,按照说明安装了eclipse编译了程序并且挂载到了ESM6800 /mnt/nfs下。但是运行程序显示No such file or directory。

file了下程序显示如下:

ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.3, for GNU/Linux 2.6.16, not stripped

在/usr/bin的文件夹下面找到一个可执行的hello程序,属性如下:

ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 2.6.32,BuildID[sha1]=4688fce88b00555eba95d21005ca4ea834a0595c7, stripped

是eclipse GCC版本不对还是什么原因?如果是的话,我应该安装什么版本的GCC?

希望各位能解答本新手的疑问,不胜感激!


  单帖管理 | 引用 | 回复 回到顶部
帅哥,在线噢!
hzc
  2楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信 员工
等级:业余侠客
  发帖心情 Post By:2018-4-16 10:18:00 [只看该作者]

你好,工具链就是用我们提供的版本就可以了。

根据/usr/bin目录下的文件信息看,请问使用的板子应该是ESM6800H或者ESM6800V吗?如果是这两个版本,需要参考对应这两个版本的开发安装说明,安装在Linux机器下使用的eclipse。

如果手上没有对应的资料文件,可以留下邮箱,我们将资料发给你。


  单帖管理 | 引用 | 回复 回到顶部
帅哥哟,离线,有人找我吗?
linux新手
  3楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信
等级:新手上路
  发帖心情 Post By:2018-4-17 21:11:00 [只看该作者]

使用的是ESM6800V,使用的开发环境是贵司提供的windows上的eclipse,我的邮箱是  hwdongyang1994@163.com,谢谢。


  单帖管理 | 引用 | 回复 回到顶部
帅哥,在线噢!
hzc
  4楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信 员工
等级:业余侠客
  发帖心情 Post By:2018-4-18 10:24:00 [只看该作者]

你好,已经把相关资料发送到邮箱了,请查收。


  单帖管理 | 引用 | 回复 回到顶部
帅哥哟,离线,有人找我吗?
linux新手
  5楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信
等级:新手上路
  发帖心情 Post By:2018-4-18 16:36:00 [只看该作者]

已收到,谢谢!


  单帖管理 | 引用 | 回复 回到顶部
帅哥,在线噢!
hzc
  6楼 | 信息 | 搜索 | 邮箱 | 主页


加好友 发短信 员工
等级:业余侠客
  发帖心情 Post By:2018-4-18 18:04:00 [只看该作者]

不用客气,如果遇到问题,请随时和我们联系。图片点击可在新窗口打开查看


  单帖管理 | 引用 | 回复 回到顶部

返回版面帖子列表

【新手求助】eclipse编译的程序无法在ESM6800运行

用户名:          
内容:
               签名